Repair Ambassadeur Thumb Bar Spool Release.

Started by rakulack, May 23, 2022, 12:28:34 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


I have an ambassadeur 5600C4 Casting Reel with a foot # 070110 /46 and the push lever to release the spool won't activate.  As you can see, If you look very close. the smaller pin that activates the release is worn down to a point so short it doesn't work the mechanism in the side plate.  Is the only solution to try and find a whole new frame?  I tried to grab the pin but it is so short and tapered to a point that I can't get it.  I was hoping to try to pull it out farther. If it was pressed in and I could get it out and file it to a flat end like it was new and epoxy it in so it would work.  ANY SUGGESTIONS ABOUT DOING A FIX OR not spending an arm and a let for a new frame (If I could find one)      Thank you            Roger Kulack,  Lewiston, MN


Gently using a flush cut pliers to grasp it and pulling it out, has always worked for me. A side to side twist while pulling.


Got it.  Tried a pliers and couldn't get it so I used a fingernail clipper and got it out.  Now just have to figure out if I should grind it so it is flush and how much epoxy to put in.  Thanks much    Roger


The catch pin on the thumb bar is supposed to be pointed, no need to grind it flat.  You can secure it in the thumb bar with a dab of superglue if need be, but these are press fit from the factory.  As long as it doesn't have excessive play and takes a bit of force to move the pin, you can forgo the adhesive.  Those pins usually get pushed in when the crank side is reattached without holding the thumb bar in the up position.