alan tani @ alantani.com fishing reel repair rebuild tutorial TLD15 - can't remove cooling shield
Reel Repair by Alan Tani
February 27, 2020, 09:01:59 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
 
   Home   Help Search Login Register  
Pages: 1 [2]   Go Down
  Print  
Author Topic: TLD15 - can't remove cooling shield  (Read 9620 times)
0 Members and 1 Guest are viewing this topic.
septicsac
Member
*
Offline Offline

Posts: 25


« Reply #15 on: January 21, 2010, 10:43:47 PM »

Got the cooling shields off using a rubber clamp and plenty of elbow grease Roll Eyes
Also got in touch with avet and they are sending out new bearing to me free of charge Grin
Logged
BigT
Member
*
Offline Offline

Posts: 111


« Reply #16 on: January 21, 2010, 10:59:58 PM »

Thanks. I have found the Australian distributor of the carbonex washers and he's not too far from me in Cairns (Australia that is). For any Aussies who stumble on this, go to this site ... http://jackerskine.com/index.html

G'day Whiteman,
I'm down on the  Gold Coast (sort of like the Miami of Australia to those reading from the USA Grin)

I can highly recommend getting bearings and drag components from Smoothdrag and Boca Bearings direct... Their customer service, speed and communication is a step up on anything I get from anywhere in Australia (sad to say).

Cheers, BigT
Logged

more of my rebuilds on
http://www.fishraider.com.au
Whiteman
Member
*
Offline Offline

Posts: 51


« Reply #17 on: January 22, 2010, 04:31:31 AM »

Thanks BigT. I'm thrashing a Tyrnos 16 at the moment so the 15's take a back seat as floaters for Spaniards and Cobia for which they are doing a fine job (with upgraded drags - thanks again Alan).
Logged

Visit http:\\www.bbbalc.com
MITCHBEGIN
Member
*
Offline Offline

Posts: 1


« Reply #18 on: April 04, 2010, 10:04:58 AM »

took apart a new TLD 15 to lube it per instructions/video on this forum.   Put it back together but the main spoon will not engage.  seems to be in free spool all the time.

What did I do wrong except take it apart in the first place?
Logged
alantani
admin
Administrator
Member
*****
Online Online

Posts: 18098



« Reply #19 on: April 04, 2010, 11:26:52 AM »

mitch, can you call me? 408-219-1149.  Alan
Logged

send me an email at alantani@yahoo.com for questions!
redsetta
Moderator
Member
****
Offline Offline

Posts: 2774


Auckland, New Zealand


« Reply #20 on: January 26, 2011, 06:22:31 PM »

Hi Alan,
I've done about a dozen TLDs and, from time to time, a little Inox runs out of the inner spool bearings during reassembly and dampens the canvas drag washer. I've always assumed this wasn't really an issue (my TLD15 seems to run fine, despite several rebuilds), but in the pursuit of perfection I'm now wondering if this is in fact an error. When you say these washers 'have to stay dry', do you mean 'completely'?
Thanks (and thanks for such a cracker site).
Logged

Fortitudine vincimus - By endurance we conquer
alantani
admin
Administrator
Member
*****
Online Online

Posts: 18098



« Reply #21 on: January 27, 2011, 07:33:22 PM »

you'll know if it's a problem because the drags will stick.  if they're smooth, then stick to what you've been doing.  you're obviously doing it right!
Logged

send me an email at alantani@yahoo.com for questions!
Pages: 1 [2]   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines
Simple Audio Video Embedder
Valid XHTML 1.0! Valid CSS!
Page created in 0.704 seconds with 19 queries.